Russian Invasion of Ukraine🇺🇦
Incident Report for Candy Bazaar
Update
We have stopped shipping to Russia and Belarus in response to the countries actions against innocent civilians in #Ukraine🇺🇦
Posted Apr 24, 2022 - 11:48 CDT
Update
We are continuing to monitor our websites and safeguard our customer's sensitive data against potential hackers and cyber attacks. Orders outside of the US will be delayed in processing.
Posted Apr 24, 2022 - 11:46 CDT
Monitoring
We strongly condemn the Russian Federation's invasion of Ukraine and its actions targeted against innocent civilians of the sovereign territory.
Posted Feb 24, 2022 - 11:43 CST
This incident affects: Websites (candybazaar.com).