We are not currently offering telephone support.
Incident Report for Candy Bazaar
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 13, 2022 - 14:03 CDT
Investigating
We are not currently offering telephone support.
Posted May 13, 2022 - 14:03 CDT
This incident affects: Support (Contact Center).